Operation of Garmin G5/ GAD 29B with Century IIB Autopilot.
Votes
Open

Can someone guide me on the proper way to use G5 with a Century IIB autopilot.  GPSS mode work fine for me.  but where I have issues is getting it to Track the localizer.  I am think is something  to do with my button pushes.  One of my partners was able to get it to work.  But I have not been successful.  From talking to him it sounds like we are doing the same thing  but getting different results.  It definitely does not work like it did for localizer with the NSD 360A installed. 

7 Replies
Votes
1433 Posts

How are you engaging the LOC tracking?  Are you turning the GPSS off, selecting the A/P ON and HDG ON switches on the main C-IIB control box, and selecting LOC NORM on the Coupler Mode Select knob?

Votes

Yes But, In this Order.   Nav to the IAF  using GPS and GPSS,  AP on Heading on,  in heading.  That works fine.  About 2 mi from the fix GPSS off, VLOC on the 430W,  Loc on mode switch as the needle comes in.  Does not seem to capture.  This worked before with the NSD 360A HSI. 

Votes
1433 Posts

It may be an installation issue.  Try calling Garmin Tech Support at 866-739-5687.  And please post whatever they tell you for others to learn.

Votes
1433 Posts

BTW, when you hit the CDI button on the 430 to switch from GPS to VLOC, did the G5 also show a change in mode from GPS to VLOC?

Votes
Yes it did, what puzzles me, is that one of our club members reports it working for him, but myself and and another member had the same issue.  I will post what the final answer to this is.

             -Dave
Votes

I had problems with my G5/STEC30 tracking and it turned out to be an installation problem.  The STEC autopilot had to be reconfigured to use a KI525 heading indicator, not the one installed.  You may want to review the autopilot installation, starting at page 150, manual: